MacOS 10.15.4

Got a problem with Viscosity or need help? Ask here!

gvoneop

Posts: 1
Joined: Thu Mar 26, 2020 8:32 pm

Post by gvoneop » Thu Mar 26, 2020 8:38 pm
Hi,

This topic is just for inform you:

After the upgrade to macOS 10.15.4, we have this message :

Image

Thk
Attachments
Capture d’écran 2020-03-26 à 10.29.07.png
Capture d’écran 2020-03-26 à 10.29.07.png (87.61 KiB) Viewed 5592 times

James

User avatar
Posts: 1985
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Fri Mar 27, 2020 10:14 am
Hi gvoneop,

Thanks for the report. We're aware that Apple are deprecating kernel extensions in the next version of macOS, and we'll have a solution in place for TAP connections under macOS 10.16.

Currently we're waiting on Apple to both a) Release information on what new APIs will be available in macOS 10.16 to support Layer 2 network interfaces, and b) Approval from Apple for access to the DriverKit framework.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

eggo

Posts: 1
Joined: Thu Apr 02, 2020 3:42 am

Post by eggo » Thu Apr 02, 2020 3:45 am
I predict you will get lots of queries on this topic (it's why I came here), so perhaps a blog/twitter post and a quick blurb on your instructions page would deflect much of this traffic?

James

User avatar
Posts: 1985
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Fri Apr 03, 2020 6:26 pm
Hi eggo,

Information can be found in our 1.8.5 release blog post :)
https://www.sparklabs.com/blog/viscosit ... ion-1-8-5/

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
4 posts Page 1 of 1