no connection after upgrading to 1.3.1 / 1.3.0

Got a problem with Viscosity or need help? Ask here!

dumitru

Posts: 2
Joined: Thu Jul 07, 2011 3:06 am

Post by dumitru » Thu Jul 07, 2011 3:07 am
This is happening on the Windows version as well. After the upgrade I have exactly the same issue.
Is Sparklabs working on a fix or need more logs?
Thank you

ElGrowZone

Posts: 8
Joined: Thu Jun 30, 2011 10:32 pm

Post by ElGrowZone » Thu Jul 07, 2011 6:39 am
Hi James,

here you go:
Jul 06 22:34:21: Viscosity 1.3.3 (1024)
Jul 06 22:34:21: Checking reachability status of connection...
Jul 06 22:34:23: Connection is reachable. Starting connection attempt.
Jul 06 22:34:30: OpenVPN 2.2.0 x86_64-apple-darwin10.7.0 [SSL] [LZO2] [PKCS11] [eurephia] built on Jun 17 2011
Jul 06 22:34:29: NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Jul 06 22:34:31: WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Jul 06 22:34:31: LZO compression initialized
Jul 06 22:34:31: UDPv4 link local: [undef]
Jul 06 22:34:31: UDPv4 link remote: 82.198.201.1:1194
Jul 06 22:34:32: [OpenVPN_Server] Peer Connection Initiated with 82.198.201.1:1194

That ALL. That and a show growl apperance: http://cl.ly/8DVN

Greetings,

Volker

nellie4568

Posts: 1
Joined: Fri Jul 08, 2011 6:05 pm

Post by nellie4568 » Fri Jul 08, 2011 6:11 pm
Hey all,
I was having an identical issue after updating. A full connection removal and re-import of my ovpn files/keys etc solved the problem for me.
Best of luck!

dumitru

Posts: 2
Joined: Thu Jul 07, 2011 3:06 am

Post by dumitru » Sat Jul 09, 2011 11:16 am
nellie4568 wrote:
Hey all,
I was having an identical issue after updating. A full connection removal and re-import of my ovpn files/keys etc solved the problem for me.
Best of luck!
nellie, thanks a lot. That worked for me too.
Although I think the bug has to be fixed since it's unacceptable to behave like this after the upgrade. Wondering if someone is watching these threads or the support emails, since I haven't received a response from them in 2 days.
:: sad ::

Eric

User avatar
Posts: 973
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Sat Jul 09, 2011 4:50 pm
Nellie,

Thank you for providing this solution.

Dumitru I have replied to your email, I apologise for the delay, it's been a busy few days for us.

The reason we think that Nellie's solution solved the problem was some users who upgraded to 1.3.0 didn't have their TAP drivers upgraded, either because they did not click "Install" at the driver prompt, or Windows didn't upgrade the existing TAP Adapters due to an antivirus program or similar blocking it.

Removing and re-adding the connection will work, alternatively, simply deleting the 'dev-node' command by Editing your connection and going to the Advanced tab then saving the connection should also solve this problem.

If anyone else experiences this problem, we would greatly appreciate you trying to remove the dev-node command, and letting us know if this resolves the issue so we can prevent this happening again in future releases.

Regards,

Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

gveloper

Posts: 1
Joined: Sun Jul 10, 2011 8:29 am

Post by gveloper » Sun Jul 10, 2011 8:34 am
Removing the dev line has no effect here. It creates the new device each time, but still says "connection initiated" followed by the popup saying it's been disconnected, and nothing else in the log. I've even tried re-installing twice, since this was a critical workstation.

Eric

User avatar
Posts: 973
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Sun Jul 10, 2011 2:32 pm
Hi gveloper,

Does deleting then re-adding the connection fix the problem?

If not, assuming you didn't have any problems with 1.2.0, could you please send a copy of your configuration and log output to our support email so we can see if something else is causing issues. You can find our support contact information here - http://www.thesparklabs.com/support/

Regards,

Eric.
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

James

User avatar
Posts: 1980
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Sun Jul 10, 2011 5:51 pm
Hi ElGrowZone,

Do you have Pogoplug installed? Or any other software installed that could be preventing Viscosity from loading its tun/tap drivers? You can check by running the command "kextstat | grep viscosity". If you don't see two entries it means something is preventing Viscosity from loading the drivers.

You should also check the Console log for warnings and error messages from OpenVPN itself (it will usually contain more detail than what you see in the Details window log). It may alert you to what is going on.

Regards,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

ElGrowZone

Posts: 8
Joined: Thu Jun 30, 2011 10:32 pm

Post by ElGrowZone » Mon Jul 11, 2011 7:14 pm
Hi James,

tun and tap seem to be loaded:

131 0 0x81af5000 0x6000 0x5000 com.viscosityvpn.Viscosity.tap (1.0) <7 5 4 1>
132 0 0x81bbc000 0x6000 0x5000 com.viscosityvpn.Viscosity.tun (1.0) <7 5 4 1>

following is the console log of a connection try:

11.07.11 11:07:08 openvpn[29245] OpenVPN 2.2.0 x86_64-apple-darwin10.7.0 [SSL] [LZO2] [PKCS11] [eurephia] built on Jun 17 2011
11.07.11 11:07:09 openvpn[29248] NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
11.07.11 11:07:11 openvpn[29248] WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
11.07.11 11:07:11 openvpn[29248] LZO compression initialized
11.07.11 11:07:11 openvpn[29248] UDPv4 link local: [undef]
11.07.11 11:07:11 openvpn[29248] UDPv4 link remote: 82.198.201.1:1194
11.07.11 11:07:12 openvpn[29248] [OpenVPN_Server] Peer Connection Initiated with 82.198.201.1:1194
11.07.11 11:07:14 openvpn[29248] viscosity_foreign_option_1=dhcp-option DNS 172.16.6.1
11.07.11 11:07:14 openvpn[29248] viscosity_foreign_option_2=dhcp-option DOMAIN megatel.de
11.07.11 11:07:14 openvpn[29248] TUN/TAP device /dev/tun0 opened
11.07.11 11:07:14 openvpn[29248] /sbin/ifconfig tun0 delete
11.07.11 11:07:14 openvpn[29248] WARNING: External program may not be called unless '--script-security 2' or higher is enabled. Use '--script-security 3 system' for backward compatibility with 2.1_rc8 and earlier. See --help text or man page for detailed info.
11.07.11 11:07:14 openvpn[29248] NOTE: Tried to delete pre-existing tun/tap instance -- No Problem if failure
11.07.11 11:07:14 openvpn[29248] /sbin/ifconfig tun0 172.16.6.17 172.16.6.18 mtu 1500 netmask 255.255.255.255 up
11.07.11 11:07:14 openvpn[29248] Mac OS X ifconfig failed: external program fork failed
11.07.11 11:07:14 openvpn[29248] Exiting

seems 'something' fails - at least a sign!

:/ Volker

James

User avatar
Posts: 1980
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Jul 12, 2011 1:09 am
Hi ElGrowZone,

It looks suspiciously like you have an up script set. How do you get on if you do the following?

1. Edit your connection in Viscosity
2. Click on the Advanced tab
3. Remove any up/down script commands (lines that start with "up" or "down", followed by a command or script location)
4. Click Save and try connecting

If that fails, try adding the command "script-security 2" (no quotes) on a new line in the same advanced commands area, and try connecting again.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
24 posts Page 2 of 3