After updating fails to connect. Keeps in authenticating status

Got a problem with Viscosity or need help? Ask here!

mplarumbe

Posts: 2
Joined: Fri Feb 23, 2024 7:15 am

Post by mplarumbe » Fri Feb 23, 2024 9:52 am
Today I have updated Viscosity to version 1.11 and since then it fails to connect to my company’s network. It keeps showing “authenticating”. This is a section of the log file.

2024-02-22 14:50:38: State changed to Connecting
2024-02-22 14:50:38: Resolving address: hcx088vn72b.sn.mynetname.net
2024-02-22 14:50:38: Resolving address: hcx088vn72b.sn.mynetname.net
2024-02-22 14:50:38: Valid endpoint found: 186.22.124.236:1194:tcp-client
2024-02-22 14:50:38: TCP/UDP: Preserving recently used remote address: [AF_INET]186.22.124.236:1194
2024-02-22 14:50:38: Attempting to establish TCP connection with [AF_INET]186.22.124.236:1194
2024-02-22 14:50:38: TCP connection established with [AF_INET]186.22.124.236:1194
2024-02-22 14:50:38: TCPv4_CLIENT link local: (not bound)
2024-02-22 14:50:38: TCPv4_CLIENT link remote: [AF_INET]186.22.124.236:1194
2024-02-22 14:50:38: State changed to Authenticating
2024-02-22 14:50:41: Connection reset, restarting [0]
2024-02-22 14:50:41: SIGUSR1[soft,connection-reset] received, process restarting
2024-02-22 14:50:41: Viscosity Mac 1.11 (1675)
2024-02-22 14:50:41: Viscosity OpenVPN Engine Started
2024-02-22 14:50:41: Running on macOS 14.2.1

I would appreciate your help so solve this problem.
Best regards

James

User avatar
Posts: 2316
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Fri Feb 23, 2024 3:53 pm
Hi mplarumbe,

It looks likely the OpenVPN server is rejecting your connection attempt. It may be significantly out-of-date, or using an incomplete OpenVPN protocol implementation (aka Mikrotik routers). Try adjusting the compatibility setting as described in the following article:
https://www.sparklabs.com/support/kb/ar ... envpn-2-6/

If you're still stuck, try reaching out to your VPN Provider to see whether they can supply an updated configuration file for you.

Cheers,
James
Web: https://www.sparklabs.com
Support: https://www.sparklabs.com/support
Twitter: https://twitter.com/sparklabs

mplarumbe

Posts: 2
Joined: Fri Feb 23, 2024 7:15 am

Post by mplarumbe » Sat Feb 24, 2024 4:18 am
Hi James,

Thank you for your kind assistance.

Certainly, as you mentioned in your post, we use a Mikrotik router on the server side.

The quick fix I found is to change the compatibility of my connection to OpenVPN 2.4 (instead of "Latest")

Although the connection is working all right, I am aware of the risks, therefore I informed the situation to the IT staff to update Mikrotik to be able to manage OpenVPN 2.6

Best regards.
3 posts Page 1 of 1