"Remember my Credentials" is disabled after Windows update

Got a problem with Viscosity or need help? Ask here!

darrendavid

Posts: 2
Joined: Tue Jan 28, 2020 10:11 pm

Post by darrendavid » Tue Jan 28, 2020 10:16 pm
Hi all-

I've had Viscosity installed for years now with several connections I'd use regularly, and for most connections I had credentials stored so they'd quickly reconnect at startup. After this latest big Windows 10 update, however, something changed and now all connections have "Remember my Credentials" greyed out/disabled and require manual credential entry on every connection (e.g. I can't save the credentials).

I checked Settings.xml and
Code: Select all
PasswordStorageSupport 
is set to
Code: Select all
YES
. Any thoughts as to what might be amiss?

Eric

User avatar
Posts: 969
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Jan 29, 2020 8:11 am
Hi Darren,

Is this a work/corporate issued machine or a personal laptop/desktop?
Is your Viscosity license personal or work issued?
If both of the above are no, are you logging into your laptop with a Microsoft account? If so has this account ever been used for work purposes?
Could you please check if there is a file located at C:\Program Files\Viscosity\GlobalSettings.xml?
Please also check your Settings.xml for a "PasswordSupport" key and value.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

darrendavid

Posts: 2
Joined: Tue Jan 28, 2020 10:11 pm

Post by darrendavid » Wed Jan 29, 2020 11:55 am
Hi Eric-

That was the trick - I needed to update GlobalSettings.xml to YES. This is a work license I'm using on a work machine.

Darren
3 posts Page 1 of 1