[Solved] IPRedator - State changed to Connecting

Got a problem with Viscosity or need help? Ask here!

tridy

User avatar
Posts: 22
Joined: Sun Dec 23, 2012 3:56 am

Post by tridy » Fri Dec 26, 2014 3:24 am
Hello.

I have had several issues with --ping-restart and have contacted the provider (IPRedator) who said that this is most likely due to the DNS problems. So, I have assigned their own DNS servers and now instead of looping the ping, the connection hangs on the "State changed to Connecting:"

Image

The manual Disconnect and Connect connects as expected and the connection works after that.

Could someone help me with that, please.
Last edited by tridy on Thu Jan 29, 2015 9:17 am, edited 1 time in total.

tridy

User avatar
Posts: 22
Joined: Sun Dec 23, 2012 3:56 am

Post by tridy » Wed Dec 31, 2014 10:37 pm
after I have added 4 dns severs, first OpenDNS ones and then IPRedator ones,
Code: Select all
208.67.222.222, 208.67.220.220, 194.132.32.32, 46.246.46.246
It is going back to the looping --ping-restart problem:
Code: Select all
Dec 31 12:23:18: [UNDEF] Inactivity timeout (--ping-restart), restarting
Dec 31 12:23:18: SIGUSR1[soft,ping-restart] received, process restarting
Dec 31 12:23:18: State changed to Connecting
Dec 31 12:23:19: UDPv4 link local: [undef]
Dec 31 12:23:19: UDPv4 link remote: [AF_INET]46.246.43.130:1194
Dec 31 12:24:18: [UNDEF] Inactivity timeout (--ping-restart), restarting
Dec 31 12:24:18: SIGUSR1[soft,ping-restart] received, process restarting
Dec 31 12:24:18: State changed to Connecting
Dec 31 12:24:19: UDPv4 link local: [undef]
Dec 31 12:24:19: UDPv4 link remote: [AF_INET]46.246.47.2:1194
Dec 31 12:25:18: [UNDEF] Inactivity timeout (--ping-restart), restarting
Dec 31 12:25:18: SIGUSR1[soft,ping-restart] received, process restarting
Dec 31 12:25:18: State changed to Connecting
Dec 31 12:25:19: UDPv4 link local: [undef]
Dec 31 12:25:19: UDPv4 link remote: [AF_INET]46.246.37.130:1194
Dec 31 12:26:18: [UNDEF] Inactivity timeout (--ping-restart), restarting
Dec 31 12:26:18: SIGUSR1[soft,ping-restart] received, process restarting
Dec 31 12:26:18: State changed to Connecting
Dec 31 12:26:19: UDPv4 link local: [undef]
Dec 31 12:26:19: UDPv4 link remote: [AF_INET]46.246.43.130:1194
Dec 31 12:27:18: [UNDEF] Inactivity timeout (--ping-restart), restarting
Dec 31 12:27:19: SIGUSR1[soft,ping-restart] received, process restarting
Dec 31 12:27:19: State changed to Connecting
Dec 31 12:27:19: UDPv4 link local: [undef]
Dec 31 12:27:19: UDPv4 link remote: [AF_INET]46.246.47.2:1194
Dec 31 12:28:18: [UNDEF] Inactivity timeout (--ping-restart), restarting
Dec 31 12:28:18: SIGUSR1[soft,ping-restart] received, process restarting
Dec 31 12:28:18: State changed to Connecting
Dec 31 12:28:19: UDPv4 link local: [undef]
Dec 31 12:28:19: UDPv4 link remote: [AF_INET]46.246.37.130:1194
So, what is actually the problem here?
When I do manual Disconnect and Connect), it (re)connects right away. Could Viscosity do the same thing?
What is it that is making it into a loop?

Thanks.

Eric

User avatar
Posts: 1023
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Jan 05, 2015 11:33 am
Hi tridy,

Please have a read through this forum topic as it covers the issues faced quite extensively and provides a solution you can try at the end that a user has contributed and found successful with iPredator. Please let us know if you have further questions to this.

http://sparklabs.com/forum/viewtopic.php?f=9&t=1413

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

tridy

User avatar
Posts: 22
Joined: Sun Dec 23, 2012 3:56 am

Post by tridy » Thu Jan 29, 2015 9:17 am
4 posts Page 1 of 1