Version 1.4.1 does not recognize certificate on token

Got a problem with Viscosity or need help? Ask here!


Posts: 6
Joined: Wed Nov 14, 2012 2:19 am

Post by pippobaudo » Wed Nov 14, 2012 2:45 am
Hi, I just upgraded Viscoisty to latest version.
I had several VPN Connection configured to use a certificate on a token.
Those are not working anymore.
Viscosity prompt with a window for selecting the certificate from the token but no list of certificate is available
I tried then to select the certificate in the Connection configuration and again viscosity is not able to give me with the list of certificate on the token

Please let me know how I can solve the problem



Posts: 6
Joined: Wed Nov 14, 2012 2:19 am

Post by pippobaudo » Wed Nov 14, 2012 9:52 pm
after some investigation I realized the following:
- everything work fine if openvpn 2.2 is used, but to use it I had to replace under \Program Files\Viscosity\Resources the openvpn.exe file with the openvpn.exe version 2.2
- the switch between OpenVpn 2.2 and 2.3 available in viscosity under the Preference/Advanced Tab does not work

Finally it seems the problem I had with viscosity using openvpn version 2.3 is related to a bug of openvpn and this is the patch published today ... devel/7129

when Sparklabs is going to update version 1.4.1 81164)?




User avatar
Posts: 1973
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Nov 15, 2012 4:12 pm
Hi pippobaudo,

Thanks for posting how your solved the issue - I'm sure it will be handy for others.

The 2.3 release bundled with Viscosity is an early alpha version (with some patches of our own to fix some bugs), so we'll be looking at moving to the latest Release Candidate version with the next update (including the addition of the PKCS#11 patch if the OpenVPN team don't have it on the roadmap for inclusion in the next Release Candidate soon).

James Bekkema
Viscosity Developer

3 posts Page 1 of 1