Set TAP-Windows TUN subnet mode network/local/netmask - FAILED

Got a problem with Viscosity or need help? Ask here!

donal.mcnamee

Posts: 3
Joined: Fri Dec 20, 2019 11:07 pm

Post by donal.mcnamee » Fri Dec 20, 2019 11:16 pm
Hello,

I just migrated my laptop to new hardware (i.e. imaged the disk and restored it on the new laptop.)
After updating a few drivers, etc. everything worked fine - except Viscosity.

Now when I try to connect to any of my VPN connections that were working before, I see the following error in the connection log.
Code: Select all
Dec 20 12:05:42 : Set TAP-Windows TUN subnet mode network/local/netmask = 10.0.7.0/10.0.7.3/255.255.255.0 [FAILED]
I'm not sure why this is happening. I've tried completly uninstalling and reinstalling Viscoity and removed and recreated the VPN connections - but to no avail.

Any reason why this 'Set TAP-Windows TUN subnet mode' command is failing?

I'm running Windows 10 (Version: 1903, Build: 18362.296) and Viscosity 1.8.3

Full extract from log below.
Thanks,
Donal.
Code: Select all
Dec 20 12:05:40 : State changed to Connecting
Dec 20 12:05:40 : Viscosity Windows 1.8.3 (1643)
Dec 20 12:05:40 : Running on Microsoft Windows 10 Pro 64 bit
Dec 20 12:05:40 : Running on .NET Framework Version 4.8.03752.528040
Dec 20 12:05:40 : Bringing up interface...
Dec 20 12:05:40 : OpenVPN 2.4.8 Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [AEAD] built on Nov 12 2019
Dec 20 12:05:40 : library versions: OpenSSL 1.1.1d  10 Sep 2019, LZO 2.10
Dec 20 12:05:40 : Checking reachability status of "185.52.92.218"...
Dec 20 12:05:41 : Server reachable. Connecting to 185.52.92.218:1194:udp.
Dec 20 12:05:41 : TCP/UDP: Preserving recently used remote address: [AF_INET]<IP_REMOVED>:1194
Dec 20 12:05:41 : UDP link local (bound): [AF_INET][undef]:1194
Dec 20 12:05:41 : UDP link remote: [AF_INET]<IP_REMOVED>:1194
Dec 20 12:05:41 : State changed to Authenticating
Dec 20 12:05:41 : WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Dec 20 12:05:41 : [carrickPfSense] Peer Connection Initiated with [AF_INET]<IP_REMOVED>:1194
Dec 20 12:05:42 : State changed to Connecting
Dec 20 12:05:42 : WARNING: Failed to get interface information for MTU. Element not found
Dec 20 12:05:42 : WARNING: Failed to get interface information for MTU. Element not found
Dec 20 12:05:42 : TAP-WIN32 device [] opened: \\.\Global\{5B51A01F-9EAC-4244-B948-E13A5F5ADE8D}.tap, index: -1
Dec 20 12:05:42 : Set TAP-Windows TUN subnet mode network/local/netmask = 10.0.7.0/10.0.7.3/255.255.255.0 [FAILED]
Dec 20 12:05:42 : Exiting due to fatal error
Dec 20 12:05:42 : State changed to Disconnected

Eric

User avatar
Posts: 988
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Jan 03, 2020 12:15 pm
Hi Donal,

It looks like the driver may not have installed correctly. Could you please open up Device Manager (Right click Start Button), go to Networking adapters and see if any Viscosity Virtual Adapters are listed here. If so, right click, go to Properties, click Enable if the option is there and then see what the device status is?

If you see any unknown devices here, please restart your computer and reinstall Viscosity again. Please also ensure the date and time are correct on your PC and Windows Updates have been installed or drivers can fail to install.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

donal.mcnamee

Posts: 3
Joined: Fri Dec 20, 2019 11:07 pm

Post by donal.mcnamee » Fri Jan 17, 2020 6:28 pm
Hi Eric,

Apologies for the delay in getting back to you on this.
So I've uninstalled and reinstalled Viscosity and I've ensured that my PC is up-to-date, but all to no avail I'm afraid.

The Viscosity adaptor is listed under my Network Connections.

[img]http://dl.archwayproducts.com/downloads/viscosity_adapter.png[/img]

However, if I look at the adapter under Device Manager, it's telling me that the "Windows cannot verify the digital signature..."

[img]http://dl.archwayproducts.com/downloads/viscosity_adapter2.png[/img]

Could this be the issue?

I've also noted that the Viscosity installer didn't ask me to 'trust' the driver when installing - (something that I've noticed it asked me to do in the past.)

Any ideas?

Many thanks,
Donal.

Eric

User avatar
Posts: 988
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Jan 17, 2020 6:50 pm
Hi Donal,

I'm afraid I haven't seen this occur on Windows 10 before, we used to see it regularly on Windows 7 due to an update that was required a long time ago.

First, could you please right click the Viscosity Virtual Adapter in device manager, select Uninstall, tick "Delete the driver software for this device" then click Uninstall.

Next, please ensure that the date and time is correct on your PC, ensure you are connected to the internet, and then check for updates once more.

Regardless of whether any updates install, next restart your PC, and then try installing Viscosity once again.
I've also noted that the Viscosity installer didn't ask me to 'trust' the driver when installing - (something that I've noticed it asked me to do in the past.)
Our driver is signed by Microsoft for Windows 10 so you won't see any dialogs pop up there, only on older versions of Windows will you see the confirmation dialog for installing the driver. Due to this, it is actually Microsoft's digital signature which is failing here which would generally indicate your certificate store is out of date or Windows Updates are missing, these are generally both caused by your date and time being way out on your PC.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

donal.mcnamee

Posts: 3
Joined: Fri Dec 20, 2019 11:07 pm

Post by donal.mcnamee » Fri Jan 17, 2020 8:15 pm
Hi Eric,

Thanks for the pointer.
I've got it working by disabeling Driver Verification as per the instructions at https://www.driverassist.com/disable-dr ... indows-10/

I acknowledge that this is not the correct way to do it. But I must look and see why the verification is not working on my machine since the upgrade to Windows 10.

Many thanks for your help,
Donal.

Eric

User avatar
Posts: 988
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Jan 20, 2020 6:33 am
Hi Donal,

Thanks for letting us know you got it working, we certainly don't recommend leaving driver verification disabled any longer than you need to.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
6 posts Page 1 of 1