Package doesn't include connections

Got a problem with Viscosity or need help? Ask here!

jmbwell

Posts: 2
Joined: Tue May 26, 2020 3:41 pm

Post by jmbwell » Tue May 26, 2020 3:51 pm
The package I build following the instructions here doesn't seem to include the connection files from my Preconfigure folder. I have just one, named "1", which has a .conf and a .key and a .crt file taken directly from my production Mac.

The build proceeds without error in Packages. It installs fine on a client. But no configs come along.

I'm using Viscosity 1.8.5 (freshly downloaded). I'm building on a Mac running 10.15.3. I've tried deploying on another Catalina Mac and on a Mojave Mac.

What should I try next? Thanks!

Directory listing:

./Viscosity Installer.pkgproj
./.DS_Store
./Preconfigure
./Preconfigure/com.viscosityvpn.Viscosity.plist
./Preconfigure/.DS_Store
./Preconfigure/Connections-Overwrite
./Preconfigure/Connections-Overwrite/.DS_Store
./Preconfigure/Connections-Overwrite/1
./Preconfigure/Connections-Overwrite/1/ta.key
./Preconfigure/Connections-Overwrite/1/config.conf
./Preconfigure/Connections-Overwrite/1/ca.crt
./Preconfigure/Connections-Append
./Preconfigure/Connections
./Preconfigure/MenuItems
./Scripts
./Scripts/postinstall
./Scripts/.DS_Store
./Scripts/preinstall
./build
./build/.DS_Store
./build/Viscosity.pkg
./build/Viscosity Installer.pkg
./Viscosity
./Viscosity/Viscosity.app
./Viscosity/Viscosity.app/Contents
(snip Viscosity.app contents)

James

User avatar
Posts: 2004
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Wed May 27, 2020 9:43 am
Hi jmbwell,

When using the standard bundling template the connections and settings will be deployed for the user running the installer only. If you're deploying the package as a different user from the end-user (i.e. deploying it using a background or system management user instead of the end-user running the package directly) you'll need to use the managed installer template instead (which will deploy the package for all users on the machine).

You can grab the managed installer template from one of the managed guides (such as the Jamf or Munki guides):
https://www.sparklabs.com/support/kb/ca ... nterprise/

If you're still stuck please email us a copy of your bundle setup (dummy credentials can be used for any connections) and we'll take a look.
https://www.sparklabs.com/support/#contact

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

jmbwell

Posts: 2
Joined: Tue May 26, 2020 3:41 pm

Post by jmbwell » Wed May 27, 2020 10:58 pm
Thank you! I have sent email to support.
3 posts Page 1 of 1