Configuring Viscosity

Got a problem with Viscosity or need help? Ask here!

iain1971

Posts: 4
Joined: Thu Oct 30, 2008 12:56 am

Post by iain1971 » Thu Oct 30, 2008 1:11 am
I am difficulty in getting Viscosity to complete the connection with an OpenVPN server. I wonder whether it is the security certificates. I have the following: ca.cert, ca.key, client1.crt, client1.csr, client1.key. Please can you tell me which one should go in which place on the preferences file. Many thanks.

James

User avatar
Posts: 1973
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Oct 30, 2008 9:16 am
Hi iain1971,

Try the following:

CA: ca.cert
Cert: client1.crt
Key: client1.key

If you have a OpenVPN config file you can tell Viscosity to import it and these will be automatically filled in for you.

Cheers
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

iain1971

Posts: 4
Joined: Thu Oct 30, 2008 12:56 am

Post by iain1971 » Thu Oct 30, 2008 6:05 pm
Hi James

Thanks for this. I get the following error: "Options error: specify only one of --tls-server, --tls-client, or --secret".

I'm not sure what else I need to configure.

James

User avatar
Posts: 1973
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Oct 30, 2008 10:32 pm
Try editing your connection again and do the following:

1. Click on the Certificates tab
2. Select Static Key from the Authentication Type drop down menu
3. Click the "Clear" button next to the Secret field
4. Click save and try connecting.

Cheers
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

iain1971

Posts: 4
Joined: Thu Oct 30, 2008 12:56 am

Post by iain1971 » Fri Oct 31, 2008 6:32 pm
James

I now get this error message: Options error: Parameter ca_file can only be specified in TLS-mode, i.e. where --tls-server or --tls-client is also specified.

Iain

iain1971

Posts: 4
Joined: Thu Oct 30, 2008 12:56 am

Post by iain1971 » Fri Oct 31, 2008 6:37 pm
James

I just logged off and on again and I now have my connection! Thanks for your help.

Iain

James

User avatar
Posts: 1973
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Fri Oct 31, 2008 11:07 pm
No problem - glad to hear you got it working.

Cheers
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

doogie04

Posts: 1
Joined: Thu Mar 17, 2011 4:00 am

Post by doogie04 » Thu Mar 17, 2011 4:39 am
I didn't see it mentioned above, but i was getting the same error. It turns out that my open vpn config file specified different cert/key file names, i.e. "client5.cert" and "client5.key". I noticed that after import the files were listed as simply cert.crt and key.key. Changing the files in the Viscosity dialog did not help -- the settings reverted after i left and came back.

To work around this problem I changed my config file on import to use the names viscosity defaulted to. I also renamed my cert/key files to the names Viscosity defaulted to. I then reimported my config and all was right with the world.

HTH,
-eric
8 posts Page 1 of 1