Cannot connect after updating to 1.7.8(1560)

Got a problem with Viscosity or need help? Ask here!

dgfdgfdfgfgdfgfdDDD

Posts: 1
Joined: Sun Apr 08, 2018 3:04 am

Post by dgfdgfdfgfgdfgfdDDD » Sun Apr 08, 2018 3:09 am
Just got a notification from Viscosity about a new update, 1.7.8(1560), and so I downloaded it and installed. However, now it can't connect to my VPN provider anymore. This is the log when trying to connect:
Code: Select all
Apr 07 19:01:35: State changed to Connecting
Apr 07 19:01:35: Viscosity Windows 1.7.8 (1560)
Apr 07 19:01:35: Running on Microsoft Windows 10 Pro
Apr 07 19:01:35: Running on .NET Framework Version 4.7.02556.461308
Apr 07 19:01:35: Bringing up interface...
Apr 07 19:01:35: WARNING: The block-outside-dns option has been ignored as it is not required under Viscosity's DNS management system. For more information please see the following article: https://www.sparklabs.com/support/kb/article/warning-the-block-outside-dns-option-has-been-ignored/
Apr 07 19:01:35: OpenVPN 2.4.5 Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Mar 28 2018
Apr 07 19:01:35: library versions: OpenSSL 1.0.2o  27 Mar 2018, LZO 2.09
Apr 07 19:01:36: Checking remote host "XXXXXX.com" is reachable...
Apr 07 19:01:37: Checking remote host "XXXXXX.com" is reachable...
Apr 07 19:01:38: No usable connection profiles are present
Apr 07 19:01:38: State changed to Disconnected
So first I removed my old profile(which has been working fine for years) and redownladed it from my provider. Still the same problems. Then I uninstalled Viscosity and rebooted my machine and reinstalled 1.7.8 and added a new profile again, still the same problem. Is there a way to downgrade to whatever stable version before 1.7.8?

Eric

User avatar
Posts: 884
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Apr 09, 2018 11:46 am
Hi,

I'm afraid we don't make previous versions available due to security updates. Are you able to resolve the address from a command line with:

nslookup XXXXXX.com

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

mitjak9

Posts: 1
Joined: Tue May 22, 2018 4:27 am

Post by mitjak9 » Tue May 22, 2018 4:30 am
I have the same problem with Viscosity 1.7.9 (1556) version!
It worked yesterday, but I am getting this error today. Same connection profile works on Viscosity for Mac.

Error:

maj 21 20:28:58: library versions: OpenSSL 1.0.2o 27 Mar 2018, LZO 2.09
maj 21 20:28:59: Checking remote host "xxxxx.no-ip.org" is reachable...
maj 21 20:29:08: Checking remote host "xxxxx.no-ip.org" is reachable...
maj 21 20:29:17: No usable connection profiles are present
maj 21 20:29:17: State changed to Disconnected

Eric

User avatar
Posts: 884
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue May 22, 2018 11:56 am
Hi,

Are you able to resolve the address from a command line with:

nslookup XXXXXX.com

Are you running any other software on this PC like Virtual Box or any advanced firewalls?

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

biarzed

Posts: 1
Joined: Fri Jun 01, 2018 10:15 am

Post by biarzed » Fri Jun 01, 2018 10:17 am
Same issue, nslookup does resolve. I use NetLimiter 4 but even with it disabled, it does not connect on both my laptop and desktop

Eric

User avatar
Posts: 884
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Jun 01, 2018 1:04 pm
Hi biarzed,

Are you using Virtual Box? Are there any errors in the Event Viewer for Viscosity Service or anything else since you last started your PC?

https://sparklabs.com/support/kb/articl ... nt-viewer/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

cameline

Posts: 1
Joined: Thu Aug 23, 2018 6:26 am

Post by cameline » Thu Aug 23, 2018 6:43 am
I just got the same problem after updating Viscosity to version 1.7.11(1576)... FYI I had not used Viscosity for 4-8 weeks prior to today.
My existing OVPN connection stopped working. From the connection log:

Aug 22 2:04:09 PM: State changed to Connecting
Aug 22 2:04:09 PM: Viscosity Windows 1.7.11 (1576)
Aug 22 2:04:10 PM: Running on Microsoft Windows 10 Enterprise N
Aug 22 2:04:10 PM: Running on .NET Framework Version 4.7.03056.461808
Aug 22 2:04:10 PM: Bringing up interface...
Aug 22 2:04:11 PM: OpenVPN 2.4.6 Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Jul 20 2018
Aug 22 2:04:11 PM: library versions: OpenSSL 1.0.2o 27 Mar 2018, LZO 2.09
Aug 22 2:04:12 PM: Checking remote host "g****.asuscomm.com" is reachable...
Aug 22 2:04:13 PM: Checking remote host "g****.asuscomm.com" is reachable...
Aug 22 2:04:13 PM: No usable connection profiles are present
Aug 22 2:04:13 PM: State changed to Disconnected

Note to answer your replies to the previous bug reports:
- I can resolve my host using nslookup.
- There are no Viscosity error messages in my Windows Application or System logs.
- I don't have VirtualBox or special firewall software other than whatever Windows 10 comes with.

I tried:
- Editing and saving the existing connection. It looked fine, saved OK with no errors, but still did not work.
- Deleting the existing connection, and reimporting the OVPN file generated by my appliance. It created a new connection with no problems. When I tried to connect, it asked me for a username and password, which I provided. Then it failed to connect, with the same connection log error "No usable connection profiles" as when I used my old existing connection.

"No usable connection profiles"? Sure looks like a bug that needs to be fixed in Viscosity.

Eric

User avatar
Posts: 884
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu Aug 23, 2018 12:35 pm
Hi cameline,

When nslookup can resolve the address but Viscosity can't, the issue is generally something blocking ViscosityService, or another application using port 53 on your PC. We've seen a few reports in the last few months of WinPcap and Wireshark blocking this port permanently. If you have any diagnostics or development tools installed on your PC, please try disabling or uninstalling them then try to connect again.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
8 posts Page 1 of 1