SparkLabs Forum.

Community Help.


Obfuscation not working

So I followed this guide exactly: https://www.sparklabs.com/support/kb/ar ... viscosity/

I've got openvpn access server running on TCP port 1194 and obfsproxy running on port 443. I set Viscosity to use TCP port 443 and select obfs2 under Transport but I'm getting this error in Viscosity when trying to connect:

Dec 17 12:22:22 PM: recv_socks_reply: TCP port read failed on recv()

Any idea what could be causing this?
Hi deviratech,

This error means that no traffic is being received from the proxy at all. Please check the firewall on your obfsproxy server to make sure it allows traffic on port 443 and from the IP address you are connecting from.

I'm also assuming you've accidentally linked the wrong guide, but just in case, here is our guide for setting up obfsproxy - http://sparklabs.com/support/kb/article ... viscosity/

Regards,
Eric
Eric wrote:
Hi deviratech,

This error means that no traffic is being received from the proxy at all. Please check the firewall on your obfsproxy server to make sure it allows traffic on port 443 and from the IP address you are connecting from.

I'm also assuming you've accidentally linked the wrong guide, but just in case, here is our guide for setting up obfsproxy - http://sparklabs.com/support/kb/article ... viscosity/

Regards,
Eric


Eric-

Thanks for the quick reply. My apologies- I did link to the incorrect guide. I can successfully connect to the OpenVPN server with Viscosity using TCP and port 443 before installing and setting up obfsproxy on the server so I don't believe it is a firewall issue. Any other things I could check to see what might be causing this issue? Thanks again for your time.
Hi deviratech,
deviratech wrote:
I can successfully connect to the OpenVPN server with Viscosity using TCP and port 443 before installing and setting up obfsproxy


If OpenVPN is listening on 443 as well, obfsproxy may not be binding to that port to listen, or if both are listening, OpenVPN might be stealing traffic from obfsproxy.

OpenVPN-AS's web interface also listens on 443 by default, you will need to change this as well to ensure no problems. OpenVPN has a pass through mode for non-VPN traffic when it is listening on 443 as well, I'm not sure how well (or if at all) this works with obfsproxy.

As mentioned before, the error your have means there is no traffic from the proxy server.

Regards,
Eric
Eric wrote:

If OpenVPN is listening on 443 as well, obfsproxy may not be binding to that port to listen, or if both are listening, OpenVPN might be stealing traffic from obfsproxy.

OpenVPN-AS's web interface also listens on 443 by default, you will need to change this as well to ensure no problems. OpenVPN has a pass through mode for non-VPN traffic when it is listening on 443 as well, I'm not sure how well (or if at all) this works with obfsproxy.

As mentioned before, the error your have means there is no traffic from the proxy server.

Regards,
Eric


I removed OpenVPN-AS and installed the regular openvpn package and it seems to be working now. Looks like it may have been a problem with OpenVPN-AS's web interface listening on port 443 as you mentioned. Thanks again for the help! :)
5 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy