Bundled Viscosity has no connections.

Got a problem with Viscosity or need help? Ask here!

CJL999

Posts: 2
Joined: Tue Oct 16, 2012 6:31 pm

Post by CJL999 » Tue Oct 16, 2012 6:50 pm
Hello there,
I have problem with bundling openvpn connections with Viscosity setup.
I followed the instructions here : http://www.sparklabs.com/support/viswin ... viscosity/

The output installation went well but there is no connections imported from my source build viscosity machine.

There are 2 connections I exported into Preconfigure/Connections folder, AA.ovpn and BB.ovpn

Here is my settings.xml in the source location;
Code: Select all
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
  <dict>
    <key>DisplayWelcome</key>
    <string>NO</string>
    <key>DetailsOnTop</key>
    <string>YES</string>
    <key>DisplayIPInMenu</key>
    <string>YES</string>
    <key>KeepFileNames</key>
    <string>NO</string>
    <key>MenuBarIcons</key>
    <string>Windows World</string>
    <key>ReconnectOnWake</key>
    <string>YES</string>
    <key>License</key>
    <string />
    <key>Launch</key>
    <string>snip</string>
    <key>5DayWarning</key>
    <string>NO</string>
    <key>10DayWarning</key>
    <string>NO</string>
    <key>PasswordSupport</key>
    <string>YES</string>
    <key>AutoUpdate</key>
    <string>NO</string>
    <key>DisconnectIfIdle</key>
    <string>NO</string>
    <key>DisconnectIfIdleTimeout</key>
    <string>10</string>
    <key>ReconnectAfterDropOut</key>
    <string>Ask</string>
    <key>ConnectAfterFail</key>
    <string>Ask</string>
    <key>FirstRun</key>
    <string>NO</string>
    <key>globalDisconnectedScript</key>
    <string />
    <key>globalConnectedScript</key>
    <string />
    <key>StartAtLogin</key>
    <string>YES</string>
    <key>OpenVPNVer</key>
    <string>Automatic</string>
    <key>LastUpdateCheck</key>
    <string>1350315031</string>
    <key>LastSuccessfulUpdateCheck</key>
    <string>1350315031</string>
    <key>ConnectionOrder</key>
    <array>
      <dict>
        <key>children</key>
        <array />
        <key>name</key>
        <string>3</string>
        <key>type</key>
        <string>openvpn</string>
      </dict>
      <dict>
        <key>children</key>
        <array />
        <key>name</key>
        <string>1</string>
        <key>type</key>
        <string>openvpn</string>
      </dict>
    </array>
  </dict>
</plist>
In destination "C:\Users\xxx\AppData\Roaming\Viscosity" folder, there is an "OpenVPN" folder but nothing there.
No connections found in client Viscosity found as well.
Here's the destination Settings.xml i got;
Code: Select all
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
  <dict>
    <key>DisplayWelcome</key>
    <string>NO</string>
    <key>DetailsOnTop</key>
    <string>YES</string>
    <key>DisplayIPInMenu</key>
    <string>YES</string>
    <key>KeepFileNames</key>
    <string>NO</string>
    <key>MenuBarIcons</key>
    <string>Windows World</string>
    <key>ReconnectOnWake</key>
    <string>YES</string>
    <key>License</key>
    <string />
    <key>Launch</key>
    <string>snip</string>
    <key>5DayWarning</key>
    <string>NO</string>
    <key>10DayWarning</key>
    <string>NO</string>
    <key>PasswordSupport</key>
    <string>YES</string>
    <key>AutoUpdate</key>
    <string>NO</string>
    <key>DisconnectIfIdle</key>
    <string>NO</string>
    <key>DisconnectIfIdleTimeout</key>
    <string>10</string>
    <key>ReconnectAfterDropOut</key>
    <string>Ask</string>
    <key>ConnectAfterFail</key>
    <string>Ask</string>
    <key>FirstRun</key>
    <string>NO</string>
    <key>globalDisconnectedScript</key>
    <string />
    <key>globalConnectedScript</key>
    <string />
    <key>StartAtLogin</key>
    <string>YES</string>
    <key>OpenVPNVer</key>
    <string>Automatic</string>
    <key>LastUpdateCheck</key>
    <string>1350315031</string>
    <key>LastSuccessfulUpdateCheck</key>
    <string>1350315031</string>
    <key>ConnectionOrder</key>
    <array />
  </dict>
</plist>
Thank you for your help.

Eric

User avatar
Posts: 869
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Oct 16, 2012 10:03 pm
Hi CJL999,

It looks like you've missed a couple of steps. First, make sure you remove the Launch key and string from the config. This is quite important. While it's not documented, it's also recommended you remove ConnectionOrder and everything under it as well.

Each connection with it's config must be in it's own folder with config and certificates, we recommend you export them from Viscosity, then copy the whole folder exactly as it is into the Connections folder for your bundle. If each connection isn't in it's own folder, they won't be imported.

If you're still having problems after trying this, please shoot us an email at [email protected] with your preconfigure bundle so we can try and spot what the problem is.

Regards,

Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

CJL999

Posts: 2
Joined: Tue Oct 16, 2012 6:31 pm

Post by CJL999 » Wed Oct 17, 2012 3:41 pm
Hi Eric,

Thank you so much for your help.
Regarding my forum post yesterday, http://www.sparklabs.com/forum/viewtopic.php?f=9&t=1145

I tried the instructions you suggested, removing Launch key, ConnectionOrder.
Unfortunately, the destination "C:\Users\xxx\AppData\Roaming\Viscosity\OpenVPN" still has no connections imported.

I will send an email to [email protected]
3 posts Page 1 of 1