SparkLabs Forum.

Community Help.


Beta: Latest Build of Viscosity for Mac

cwningen wrote:
HMAC problem is fixed! IPv6 still fails though; is there anything I can provide to help? It does work manually but otherwise it fails on two different Yosemite DP4 installs.

We haven't taken a close look at IPv6 under Yosemite as of yet, however it should be something we get around to soon.

Cheers,
James
Thanks James.
Unfortunately restart didn't help.
And there is no other VPN connection running. :cry:
iMac 21.5 (Late 2012) | 3,1 GHz i7 | 16 GB RAM | OS X 10.10 | Safari 8.0
Fixed it. Sorry for the confusion. :roll:
Don't know why but the information about the Routing was lost.
So I had to type in the list again.. Destination, Mask/Bits, Gateway... but now everything works as expected.
Thanks James for your superb support and work.
iMac 21.5 (Late 2012) | 3,1 GHz i7 | 16 GB RAM | OS X 10.10 | Safari 8.0
James wrote:
We haven't taken a close look at IPv6 under Yosemite as of yet, however it should be something we get around to soon.


Awesome, thank you James! :)
Thanks James! b19 connects and works well so far! :P :D :D :P

Cheers.
Hi, I'm also having an issue with connecting via the latests build (1.4.11b19).

Viscosity hangs while attempting to connect, and loops over the follow log message:

Code: Select all

Aug 17 16:46:06: Viscosity Mac 1.4.11 (1218)
Aug 17 16:46:06: Viscosity OpenVPN Engine Started
Aug 17 16:46:06: Running on Mac OS X 10.10
Aug 17 16:46:06: ---------
Aug 17 16:46:06: Checking reachability status of connection...
Aug 17 16:46:06: Connection is reachable. Starting connection attempt.
Aug 17 16:46:09: OpenVPN 2.3.4 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jul  2 2014
Aug 17 16:46:10: Control Channel Authentication: using '/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/connection.KUH9Hz/ta.key' as a OpenVPN static key file
Aug 17 16:46:10: Attempting to establish TCP connection with [AF_INET]174.129.39.108:843 [nonblock]
Aug 17 16:46:11: TCP connection established with [AF_INET]174.129.39.108:843
Aug 17 16:46:11: TCPv4_CLIENT link local: [undef]
Aug 17 16:46:11: TCPv4_CLIENT link remote: [AF_INET]174.129.39.108:843
Aug 17 16:46:11: Connection reset, restarting [-1]
Aug 17 16:46:11: SIGUSR1[soft,connection-reset] received, process restarting


What I've tried:

* various versions of Viscosity
* removing old config files / versions of Viscosity
* reloading client.opvn
* restarting the computer
* toggling IPv6
* verifying that the ViscosityHelper is running

Any ideas, thoughts?

Thanks in advance.
Hi,
I am a early beta tester for osx yosemite and am running the new version of viscosity, however once I try to connect I seem to be getting a can't allocate memory error yet I am sure I have enough, when in fact the helper is taking 2g of ram. Can anyone help me with this problem?.

I posted the log below
Aug 17 22:08:14: Viscosity Mac 1.4.11 (1218)
Aug 17 22:08:14: Viscosity OpenVPN Engine Started
Aug 17 22:08:14: Running on Mac OS X 10.10
Aug 17 22:08:14: ---------
Aug 17 22:08:14: Checking reachability status of connection...
Aug 17 22:08:14: Connection is reachable. Starting connection attempt.
Aug 17 22:08:17: OpenVPN 2.3.4 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jul 2 2014
Aug 17 22:08:18: WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Aug 17 22:08:18: Control Channel Authentication: using '/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/connection.y1PsjY/ta.key' as a OpenVPN static key file
Aug 17 22:08:18: UDPv4 link local: [undef]
Aug 17 22:08:18: UDPv4 link remote: [AF_INET]192.161.173.2:53
Aug 17 22:08:18: write UDPv4: Cannot allocate memory (code=12)
Aug 17 22:08:20: write UDPv4: Cannot allocate memory (code=12)
Aug 17 22:08:24: write UDPv4: Cannot allocate memory (code=12)
Aug 17 22:08:32: write UDPv4: Cannot allocate memory (code=12)
Build Notice: Viscosity 1.5b1 Now Available

If you receive an error message stating that Viscosity's helper tool was unable to be installed/updated under Yosemite please restart your computer or uninstall the old helper tool like so:

Code: Select all

sudo launchctl unload /Library/LaunchDaemons/com.sparklabs.ViscosityHelper.plist
sudo rm /Library/PrivilegedHelperTools/com.sparklabs.ViscosityHelper
sudo rm /Library/LaunchDaemons/com.sparklabs.ViscosityHelper.plist


You can subscribe to this topic by clicking on the "Subscribe topic" link at the bottom of the page to receive email notifications of new beta versions.
First, thanks for your amazing software.

Since I've switch to Yosemite, Viscosity (Stable or Beta) doesn't seem to play well with PKCS11/OpenSC anymore, it use to work fine in Mavericks.

Here is the log of an attempt of connection with a PKCS11 Smartcard.

Code: Select all

Aug 20 10:33:03: Checking reachability status of connection...
Aug 20 10:33:03: Connection is reachable. Starting connection attempt.
Wed Aug 20 10:33:03 2014 NOTE: debug verbosity (--verb 12) is enabled but this build lacks debug support.
Aug 20 10:33:05: OpenVPN 2.3.4 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Aug  9 2014
Aug 20 10:33:04: MANAGEMENT: CMD 'state on'
Aug 20 10:33:04: MANAGEMENT: CMD 'hold release'
Aug 20 10:33:04: PKCS#11: Adding PKCS#11 provider '/Library/OpenSC/lib/opensc-pkcs11.so'
Aug 20 10:33:04: PKCS#11: pkcs11h_addProvider entry version='1.11', pid=2400, reference='/Library/OpenSC/lib/opensc-pkcs11.so', provider_location='/Library/OpenSC/lib/opensc-pkcs11.so', allow_protected_auth=0, mask_private_mode=00000000, cert_is_private=0
Aug 20 10:33:04: PKCS#11: Adding provider '/Library/OpenSC/lib/opensc-pkcs11.so'-'/Library/OpenSC/lib/opensc-pkcs11.so'


Now the interesting thing is, that, If i run the following command, it does get past the pkcs11 library !

/Applications/Viscosity.app/Contents/MacOS/openvpn --config config.conf --script-security 2 --pkcs11-id 'piv_II/PKCSXXXXXXXXXXX' --verb 2


Code: Select all

.. 2014 NOTE: debug verbosity (--verb 12) is enabled but this build lacks debug support.
.. 2014 OpenVPN 2.3.4 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Aug  9 2014
.. 2014 library versions: OpenSSL 1.0.1i 6 Aug 2014, LZO 2.06
.. 2014 PKCS#11: Adding PKCS#11 provider '/Library/OpenSC/lib/opensc-pkcs11.so'
.. 2014 UDPv4 link local: [undef]
.. 2014 UDPv4 link remote: [AF_INET]x.x.x.x:1194
.. 2014 VERIFY OK: depth=1, CN=x.x.com
.. 2014 Validating certificate key usage
.. 2014 ++ Certificate has key usage  00a0, expects 00a0
.. 2014 VERIFY KU OK
.. 2014 Validating certificate extended key usage
.. 2014 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
.. 2014 VERIFY EKU OK
.. 2014 VERIFY OK: depth=0, CN=x.x.com
Enter PIV_II (PIV Card Holder pin) token Password:
.. 2014 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
.. 2014 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
.. 2014 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
.. 2014 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
.. 2014 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
.. 2014 [x.x.com] Peer Connection Initiated with [AF_INET]x.x.x.x:1194
.. 2014 Opened utun device utun0
.. 2014 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
.. 2014 /sbin/ifconfig utun0 delete
.. 2014 NOTE: Tried to delete pre-existing tun/tap instance -- No Problem if failure
.. 2014 /sbin/ifconfig utun0 10.244.0.30 10.244.0.29 mtu 1500 netmask 255.255.255.255 up


Note: I tried with OpenSC 13.0 (which use to work on Mavericks) and the last OpenSC 14.0 with the same results.
Getting this in my console, and the menu item is not showing so I cannot connect:

Code: Select all

8/20/14 9:31:22.452 AM Viscosity[672]: *** -[NSBigMutableString _getBlockStart:end:contentsEnd:forRange:stopAtLineSeparators:]: Range {0, 672} out of bounds; string length 670
166 posts

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy