[bug] key-direction not imported

Suggestions/comments/criticisms are welcome here

ratness

Posts: 2
Joined: Fri Jul 06, 2018 4:31 am

Post by ratness » Wed Nov 28, 2018 9:41 am
Mac 1.7.13b2

Using a config with 'tls-auth ta.key 1' imports fine, and (Preference, connectionname, Authentication) shows ta.key and Direction 1. Good.

Using a config with 'tls-auth [inline] 1' and a '<tls-auth>keygoeshere</tls-auth>' section imports fine, and )Preference, connectionname, Authentication) shows ta.key and Direction 1. Good.

Using a config with 'key-direction 1' and a '<tls-auth>keygoeshere</tls-auth>' imports fine, but (Preference, connectionname, Authentication) shows ta.key and Direction 'Default' instead of '1'. Not good. Shuffling 'key-direction' around in the import file, like putting the line after the inline file, doesn't change anything.

Upon import, the config.conf has 'tls-auth ta.key' and 'key-direction 1'

If I edit the connection in the gui and save the Direction as '1', config.conf cuts over to 'tls-auth ta.key 1' and 'key-direction 1'

I have no indication that this is a regression. i just discovered it while messing with prospective configs. Once imported, I can change it, which makes this different than a report from last year, I think.

James

User avatar
Posts: 1876
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Wed Nov 28, 2018 1:11 pm
Hi ratness,

Thanks for the detailed report. We'll make sure this is fixed in the next beta update.

Thanks,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1