1.0.3 Italian problem

Got a problem with Viscosity or need help? Ask here!

leyoda

Posts: 3
Joined: Sat Mar 14, 2009 9:01 pm

Post by leyoda » Sat Mar 14, 2009 9:18 pm
Hi,

In production I'm under 10.5.6 in french localisation, each time I do the upgrade to 1.0.3 version, my viscosity language go to Italian !! , why ? and where can I modify that ?
Thanks in advance

Best regards,

Leyoda

leyoda

Posts: 3
Joined: Sat Mar 14, 2009 9:01 pm

Post by leyoda » Sat Mar 14, 2009 9:20 pm
In fact I done some tests and if I only take in international settings from Leopard English and French, it's OK I obtain English for Viscosity.
So I think the last upgrade of viscosity with Italian localization put Italian if you don't have English by default ... maybe a patch for this ?

Regards,

Leyoda

James

User avatar
Posts: 1859
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Mar 17, 2009 7:07 pm
Hi Leyoda,

Mac OS X will choose the language for an application to use based on the order in the International System Preferences section. Viscosity doesn't have a French version (at least yet), so your copy of Mac OS X decided Italian (which was added in version 1.0.3) would be the next best language to use.

You can change this like so:

1. Go to the Apple menu and select System Preferences
2. Click on the International section (the blue UN flag icon)
3. Drag English so it is above Italian. For example you may like to have Francais at the very top, with English in second.
4. Quit and re-open Viscosity. It should now be in English.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

leyoda

Posts: 3
Joined: Sat Mar 14, 2009 9:01 pm

Post by leyoda » Sat Mar 21, 2009 7:06 pm
Hi,

It's done and it's work, but perhaps it would be good to do a test in the code of application to put english by default if the viscosity don't have the first language define in the user preferences ?

Regards

Leyoda
4 posts Page 1 of 1