Viscosity Disconnects Immediately

Got a problem with Viscosity or need help? Ask here!

spatel109

Posts: 1
Joined: Sat Nov 16, 2019 6:11 am

Post by spatel109 » Sat Nov 16, 2019 6:16 am
Just started randomly, was working fine an hour ago. Added logs below:
Code: Select all
2019-11-15 14:12:40: Viscosity Mac 1.8.1 (1511)
2019-11-15 14:12:40: Viscosity OpenVPN Engine Started
2019-11-15 14:12:40: Running on macOS 10.14.6
2019-11-15 14:12:40: ---------
2019-11-15 14:12:40: State changed to Connecting
2019-11-15 14:12:40: Checking reachability status of connection...
2019-11-15 14:12:40: Connection is reachable. Starting connection attempt.
2019-11-15 14:12:40: Current Parameter Settings:
2019-11-15 14:12:40:   config = 'config.conf'
2019-11-15 14:12:40:   mode = 0
2019-11-15 14:12:40:   show_ciphers = DISABLED
2019-11-15 14:12:40:   show_digests = DISABLED
2019-11-15 14:12:40:   show_engines = DISABLED
2019-11-15 14:12:40:   genkey = DISABLED
2019-11-15 14:12:40:   key_pass_file = '[UNDEF]'
2019-11-15 14:12:40:   show_tls_ciphers = DISABLED
2019-11-15 14:12:40:   connect_retry_max = 0
2019-11-15 14:12:40: Connection profiles [0]:
2019-11-15 14:12:40:   proto = udp
2019-11-15 14:12:40:   local = '[UNDEF]'
2019-11-15 14:12:40:   local_port = '[UNDEF]'
2019-11-15 14:12:40:   remote = '*****.******.*******.com' ----> (I've deleted and added ****, company reasons)
2019-11-15 14:12:40:   remote_port = '****'
2019-11-15 14:12:40:   remote_float = DISABLED
2019-11-15 14:12:40:   bind_defined = DISABLED
2019-11-15 14:12:40:   bind_local = DISABLED
2019-11-15 14:12:40:   bind_ipv6_only = DISABLED
2019-11-15 14:12:40:   connect_retry_seconds = 5
2019-11-15 14:12:40:   connect_timeout = 120
2019-11-15 14:12:40:   socks_proxy_server = '[UNDEF]'
2019-11-15 14:12:40:   socks_proxy_port = '[UNDEF]'
2019-11-15 14:12:40:   tun_mtu = 1500
2019-11-15 14:12:40:   tun_mtu_defined = ENABLED
2019-11-15 14:12:40:   link_mtu = 1500
2019-11-15 14:12:40:   link_mtu_defined = DISABLED
2019-11-15 14:12:40:   tun_mtu_extra = 0
2019-11-15 14:12:40:   tun_mtu_extra_defined = DISABLED
2019-11-15 14:12:40:   mtu_discover_type = -1
2019-11-15 14:12:40:   fragment = 0
2019-11-15 14:12:40:   mssfix = 1450
2019-11-15 14:12:40:   explicit_exit_notification = 0
2019-11-15 14:12:40: Connection profiles END
2019-11-15 14:12:40:   remote_random = DISABLED
2019-11-15 14:12:40:   ipchange = '[UNDEF]'
2019-11-15 14:12:40:   dev = 'tun'
2019-11-15 14:12:40:   dev_type = '[UNDEF]'
2019-11-15 14:12:40:   dev_node = 'utun'
2019-11-15 14:12:40:   lladdr = '[UNDEF]'
2019-11-15 14:12:40:   topology = 1
2019-11-15 14:12:40:   ifconfig_local = '[UNDEF]'
2019-11-15 14:12:40:   ifconfig_remote_netmask = '[UNDEF]'
2019-11-15 14:12:40:   ifconfig_noexec = DISABLED
2019-11-15 14:12:40:   ifconfig_nowarn = DISABLED
2019-11-15 14:12:40:   ifconfig_ipv6_local = '[UNDEF]'
2019-11-15 14:12:40:   ifconfig_ipv6_netbits = 0
2019-11-15 14:12:40:   ifconfig_ipv6_remote = '[UNDEF]'
2019-11-15 14:12:40:   shaper = 0
2019-11-15 14:12:40:   mtu_test = 0
2019-11-15 14:12:40:   mlock = DISABLED
2019-11-15 14:12:40:   keepalive_ping = 0
2019-11-15 14:12:40:   keepalive_timeout = 0
2019-11-15 14:12:40:   inactivity_timeout = 0
2019-11-15 14:12:40:   ping_send_timeout = 10
2019-11-15 14:12:40:   ping_rec_timeout = 3600
2019-11-15 14:12:40:   ping_rec_timeout_action = 2
2019-11-15 14:12:40:   ping_timer_remote = DISABLED
2019-11-15 14:12:40:   remap_sigusr1 = 0
2019-11-15 14:12:40:   persist_tun = ENABLED
2019-11-15 14:12:40:   persist_local_ip = DISABLED
2019-11-15 14:12:40:   persist_remote_ip = DISABLED
2019-11-15 14:12:40:   persist_key = ENABLED
2019-11-15 14:12:40:   passtos = DISABLED
2019-11-15 14:12:40:   resolve_retry_seconds = 1000000000
2019-11-15 14:12:40:   resolve_in_advance = DISABLED
2019-11-15 14:12:40:   username = '[UNDEF]'
2019-11-15 14:12:40:   groupname = '[UNDEF]'
2019-11-15 14:12:40:   chroot_dir = '[UNDEF]'
2019-11-15 14:12:40:   cd_dir = '[UNDEF]'
2019-11-15 14:12:40:   writepid = '[UNDEF]'
2019-11-15 14:12:40:   up_script = '[UNDEF]'
2019-11-15 14:12:40:   down_script = '[UNDEF]'
2019-11-15 14:12:40:   down_pre = DISABLED
2019-11-15 14:12:40:   up_restart = DISABLED
2019-11-15 14:12:40:   up_delay = DISABLED
2019-11-15 14:12:40:   daemon = DISABLED
2019-11-15 14:12:40:   inetd = 0
2019-11-15 14:12:40:   log = DISABLED
2019-11-15 14:12:40:   suppress_timestamps = DISABLED
2019-11-15 14:12:40:   machine_readable_output = DISABLED
2019-11-15 14:12:40:   nice = 0
2019-11-15 14:12:40:   verbosity = 5
2019-11-15 14:12:40:   mute = 100
2019-11-15 14:12:40:   status_file = '[UNDEF]'
2019-11-15 14:12:40:   status_file_version = 1
2019-11-15 14:12:40:   status_file_update_freq = 60
2019-11-15 14:12:40:   occ = ENABLED
2019-11-15 14:12:40:   rcvbuf = 0
2019-11-15 14:12:40:   sndbuf = 0
2019-11-15 14:12:40:   sockflags = 0
2019-11-15 14:12:40:   fast_io = DISABLED
2019-11-15 14:12:40:   comp.alg = 0
2019-11-15 14:12:40:   comp.flags = 0
2019-11-15 14:12:40:   route_script = '[UNDEF]'
2019-11-15 14:12:40:   route_default_gateway = '[UNDEF]'
2019-11-15 14:12:40:   route_default_metric = 0
2019-11-15 14:12:40:   route_noexec = DISABLED
2019-11-15 14:12:40:   route_delay = 0
2019-11-15 14:12:40: NOTE: --mute triggered...
2019-11-15 14:12:40: 180 variation(s) on previous 100 message(s) suppressed by --mute
2019-11-15 14:12:40: OpenVPN 2.4.7 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [MH/RECVDA] [AEAD] built on Sep 11 2019
2019-11-15 14:12:40: library versions: OpenSSL 1.0.2t  10 Sep 2019, LZO 2.10
2019-11-15 14:12:40: State changed to Disconnected
2019-11-15 14:12:41: Delaying connection reconnect attempt by 600 seconds

James

User avatar
Posts: 1924
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Mon Nov 18, 2019 12:11 pm
Hi spatel109,

This typically indicates that the OpenVPN process is unexpectedly terminating with no additional output. I recommend you try restarting your computer to rule out any stuck background ports/processes.

If that doesn't help, try updating to the latest beta version of Viscosity and see if there is any change:
https://www.sparklabs.com/support/kb/article/using-viscosity-beta-versions/

And if you're still stuck, please post a copy of your raw configuration data and we'll see if there are any config problems. You can view the raw configuration data for your Viscosity connection by opening Viscosity’s Preferences window, holding down the Option/Alt key on your keyboard, right-clicking (or control-clicking on Mac) on your connection, and selecting “View Configuration Data”.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1