vpn connection failed after new viscosity release 1.7.13

Got a problem with Viscosity or need help? Ask here!

Guma96

Posts: 2
Joined: Fri Jan 18, 2019 5:38 am

Post by Guma96 » Fri Jan 18, 2019 5:52 am
Hi ,

after the last update on Jan 15th i get the following error message:

2019-01-17 19:30:42: Viscosity Mac 1.7.13 (1478)
2019-01-17 19:30:42: Viscosity OpenVPN Engine Started
2019-01-17 19:30:42: Running on macOS 10.14.2
2019-01-17 19:30:42: ---------
2019-01-17 19:30:42: State changed to verbinde
2019-01-17 19:30:42: Checking reachability status of connection...
2019-01-17 19:30:42: Connection is reachable. Starting connection attempt.
2019-01-17 19:30:42: Note: option tun-ipv6 is ignored because modern operating systems do not need special IPv6 tun handling anymore.
2019-01-17 19:30:42: disabling NCP mode (--ncp-disable) because not in P2MP client or server mode
2019-01-17 19:30:42: Options error: Parameter tls_exit can only be specified in TLS-mode, i.e. where --tls-server or --tls-client is also specified.
2019-01-17 19:30:43: The OpenVPN subsystem could not be started.
2019-01-17 19:30:43: State changed to getrennt

Have Anybody an idea, whats wrong here…… :)
Information Release Notes:
https://www.sparklabs.com/viscosity/releasenotes/mac/
is this my problem:
updated OpenSSL updated to version 1.0.2q

James

User avatar
Posts: 1876
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Fri Jan 18, 2019 11:34 am
Hi Guma96,

Thanks for the report. This is unfortunately a regression that has made it into the 1.7.13 release. You have a couple of options available to resolve it:

1. Update to the latest 1.7.14 beta release, which should resolve the issue:
https://www.sparklabs.com/support/kb/ar ... -versions/

2. Or add the command "tls-exit false" (without quotes) to the advanced commands area for your connection:
https://www.sparklabs.com/support/kb/ar ... n-commands

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Guma96

Posts: 2
Joined: Fri Jan 18, 2019 5:38 am

Post by Guma96 » Fri Jan 18, 2019 8:12 pm
:D :D :D

Hi James,

step 1. solves the issue.

Thanks and Best Regards
Guido
3 posts Page 1 of 1