SparkLabs Forum.

Community Help.

DNS resolution is not working anymore


Today the DNS resolution when connected on a VPN with Viscosity is not working.
My Mac is resolving addresses using its default DNS servers for the current wired connection, so resolution for internal addresses is not working.

I also tried to set DNS settings with "full DNS" and nothing changed, and I finally tried to set "split DNS" specifying internal servers (,, and internal domains.

Nothing changed.

My /etc/resolv.conf remains with the default configuration:

Code: Select all

[email protected]:~$ cat /etc/resolv.conf
# macOS Notice
# This file is not consulted for DNS hostname resolution, address
# resolution, or the DNS query routing mechanism used by most
# processes on this system.
# To view the DNS configuration used by this system, use:
#   scutil --dns
#   dns-sd(1), scutil(8)
# This file is automatically generated.

My Viscosity version is 1.7.11 (1463).

Could you help me please?
Hi decibel83,

Please see the following regarding resolv.conf and some command line tools: ... unix-users

Thanks! I read that..
Do you have any idea about why DNS resolution is not working on my Mac when Viscosity is connected?
You'll need to use the tools listed is the previously linked article to confirm that DNS resolution isn't actually working: ... omain-name ... being-used

I executed the command you sent me.

dnscacheutil correctly resolves the internal domain name:

Code: Select all

[email protected]:~/.ssh$ dscacheutil -q host -a name

The command scutil --dns shows me 14 resolvers.
The first resolver has into the search domain list, but it has wrong DNS servers:

Code: Select all

nameserver[0] :
nameserver[1] :

The correct DNS servers for the domain is, which is configured into the Viscosity connection - Networking tab (Split DNS is enabled with into the domain list and as server.

But I also realized that the domain is listed in the resolver #8 with the correct DNS server.

Could you help me to find out where I am wrong, please?
When checking what DNS server/s will be used for what domain, please ensure that you're looking at the "DNS configuration (for scoped queries)" section of the output from "scutil --dns". The first "DNS configuration" section is not relevant in this regard.

6 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy