SparkLabs Forum.

Community Help.


Advanced editor, ns-cert-type is DEPRECATED

I was looking through the logs in order to resolve a daily disconnection error that has recently arisen. In doing so I noticed this:

Code: Select all

2018-09-10 04:19:24: WARNING: --ns-cert-type is DEPRECATED.  Use --remote-cert-tls instead.


I attempted to make a change for the Advanced tab in the GUI by removing ns-cert-type and replacing it with remote-cert-tls. This didn't work (rapid disconnects) so I removed remote-cert-tls and put back ns-cert-type using the Advanced tab. I still could not connect so I fired up vi and looked at the config file. Both entries were there. Seems like there may be an issue with how the Advanced tab editor is dealing with content changes...?
Hi humantypo,

The "remote-cert-tls" command corresponds to the "Require certificate was signed for server use" option (under the Options tab when editing your connection). To remove the "remote-cert-tls command you'll need to un-tick that option.

Cheers,
James
Hi James,

Yes, thanks.

I was referring to the behavior vis a vis the file itself. It seems that it is assuming the state rather than confirming if any other settings may be there.

thanks
3 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy