SparkLabs Forum.

Community Help.


DNS resolution is not working anymore

Hi.

Today the DNS resolution when connected on a VPN with Viscosity is not working.
My Mac is resolving addresses using its default DNS servers for the current wired connection, so resolution for internal addresses is not working.

I also tried to set DNS settings with "full DNS" and nothing changed, and I finally tried to set "split DNS" specifying internal servers (192.168.70.254, 1.1.1.1, 1.0.0.1) and internal domains.

Nothing changed.

My /etc/resolv.conf remains with the default configuration:

Code: Select all

[email protected]:~$ cat /etc/resolv.conf
#
# macOS Notice
#
# This file is not consulted for DNS hostname resolution, address
# resolution, or the DNS query routing mechanism used by most
# processes on this system.
#
# To view the DNS configuration used by this system, use:
#   scutil --dns
#
# SEE ALSO
#   dns-sd(1), scutil(8)
#
# This file is automatically generated.
#
search me.online
nameserver 192.168.76.1
nameserver 192.168.76.2


My Viscosity version is 1.7.11 (1463).

Could you help me please?
Thanks!
Hi decibel83,

Please see the following regarding resolv.conf and some command line tools:
https://www.sparklabs.com/support/kb/ar ... unix-users

Cheers,
James
Thanks! I read that..
Do you have any idea about why DNS resolution is not working on my Mac when Viscosity is connected?
You'll need to use the tools listed is the previously linked article to confirm that DNS resolution isn't actually working:
https://www.sparklabs.com/support/kb/ar ... omain-name
https://www.sparklabs.com/support/kb/ar ... being-used

Cheers,
James
Thanks.
I executed the command you sent me.

dnscacheutil correctly resolves the internal domain name:

Code: Select all

[email protected]:~/.ssh$ dscacheutil -q host -a name node1.dc.my.network
name: node1.dc.my.network
ip_address: 192.168.60.1


The command scutil --dns shows me 14 resolvers.
The first resolver has my.network into the search domain list, but it has wrong DNS servers:

Code: Select all

nameserver[0] : 192.168.76.1
nameserver[1] : 192.168.76.2


The correct DNS servers for the my.network domain is 192.168.70.254, which is configured into the Viscosity connection - Networking tab (Split DNS is enabled with my.network into the domain list and 192.168.70.254 as server.

But I also realized that the my.network domain is listed in the resolver #8 with the correct DNS server.

Could you help me to find out where I am wrong, please?
When checking what DNS server/s will be used for what domain, please ensure that you're looking at the "DNS configuration (for scoped queries)" section of the output from "scutil --dns". The first "DNS configuration" section is not relevant in this regard.

Cheers,
James
6 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy